如何解决“要执行请求的操作,Word­Press需要访问您网页服务器的权限”

Ourboke
Ourboke
Ourboke
16368
文章
148
评论
2021年12月3日10:48:38

从WordPress升级至5.8.2版本后,后台会一直提示我升级,然后我在用wordpress升级程序的时候,会出现如下错误连接信息:“要执行请求的操作,WordPress需要访问您网页服务器的权限。 请输入您的FTP登录凭据以继续。 如果您忘记了您的登录凭据(如用户名、密码),请联系您的网站托管商。”的错误提示,意思很明显,这是服务器给予站点的权限不够导致的。下面我们来看看如何解决。

解决方法:

1:修改配置文件

在 wp-config.php 文件最后添加以下三行:

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

2:授权目录

我用的是腾讯云服务器,LAMP 平台,即 Linux 系统,Apache 服务器,MySQL 数据库,PHP 语言;网站位置是 /var/www/html。

因此,我的授权命令为以下三行:

chown -R root /var/www/html
chmod -R 775 /var/www/html
chmod -R 777 /var/www/html

完成上述步骤后,再到Word­Press后台尝试更新版本,就可以更新了。

WordPress 判断访客浏览器类型方法 WordPress

WordPress 判断访客浏览器类型方法

现在很多主题对IE支持都不是很好,其实我们可以通过判断访问者用浏览器,然后提醒用户升级浏览器。 今天分享一下WordPress 判断访客浏览器类型方法。比如在主题模板适当位置添加: &...
让WordPress页面支持添加分类及标签 WordPress

让WordPress页面支持添加分类及标签

默认WordPress页面不支持选择分类和添加标签,可以通过下面的方法为页面添加分类及标签。 将下面代码添加到当前主题函数模板 functions.php 中: functio...